Intermittent Page Load Issues Due to AWS Outage

Incident Report for dYdX Chain

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:22 UTC

Identified

We're experiencing intermittent page load and styling failures due to an AWS outage affecting our CDN provider. Please refresh the page if you see any issues.
Posted Oct 20, 2025 - 22:27 UTC
This incident affected: Frontend (dydx.trade).