Intermittent Page Load Issues in France

Incident Report for dYdX Chain

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 16:48 UTC

Investigating

We're experiencing intermittent page load and styling failures due to issues with our CDN provider. So far the issue is confined to France.
Posted Oct 21, 2025 - 14:34 UTC
This incident affected: Frontend (dydx.trade).